Abner Filter doesn't work

Hello,

Abner Filter node doesn’t work. I tried to select different tags on the Tag settings tab in the Configuration dialog. But this node returns only PROTEIN terms.

BR, Valery Otryvankin

Standard Named Entity Filter has the same issue. I select different tags on the Tag settings tab in the Configuration dialog. But result contains only PROTEINE tags.

Unfortunately this is due to the tagging model which is used by the ABER tagger node. This model only assignes PROTEIN tags. In the next version of this node it will be possible to select the model which is used for tagging. The filter node itself should work fine.
It is planned to release a new version of the plugin at around end of October.

I tried filtering of NE Tags after assinging them with a custom dictionary which also didn’t work. Is the non-working NE-filter-problem still expected to occur?

In addition I tried other tag sets, they also didn't work. However I assigned all tagsets with a custom dictionary before so I assume this is the reason for the issue. I can filter between Terms with Tag or Terms without a Tag but it is not possible to discriminate between different tags ( I tried to assign POS/WRD; PHARMA/COUMPOUND, NE/LOCATION or NE/PERSON and different combinations with two subsequent dictionary taggers however I was not able to filter based on tag or even tag set.

I tried to filter with the "General tag set filter", "Standard named entity filter" or "POS Filter" however I could never filter specifically. My workflow looks like this:

Any idea why filterting does not work?

Hi TimB,

all Tagger Nodes (except the POS Tagger Nodes) set the tagged terms to "unmodifiable" (see Node Dialog). Terms set to unmodifiable will NOT be affected by any preprocessing node, such as e.g. filter nodes.

You can uncheck the "set tagged terms unmodifiable" in the dialog of the tagger node or you can specify in the filter dialog that the unmodifiable flag will be ignored.

Cheers, Kilian