Access to all files in Current workflow data area

Hello

I’ve been trying to access multiple files existing inside of the data folder in the workflow with the option available in the nodes but it is not working. I tryied to read them or delete them and it didn’t work. I can make the same process reading or deleting files from a folder in the Current workflow or from a folder in the file system, but it is not working inside the Current workflow data area. However if I try to read or delete one file at the time it works.

I attach some screenshots

Trying to delete multiple files inside the current workflow data area. I haven’t put any filter, but even if I try to force it to look for the table files, it seems to not finding them

Trying to delete a single file inside the same current workflow data area

BTW, I check the same in KNIME AP 4.7.7 and 5.1.1 with the same result

Thanks

Hi @lsandinop

You just need to put a “.” and it should work :slight_smile:

Best wishes
Heather

5 Likes

Hi Heather
It worked thanks!
Just another question. What if I just need to delete or read table files? I could’t make it with work.
Thanks

Hi @lsandinop

Glad that worked for you.

When you wrote your table files did you add the extension “.table”? This could be a reason why the solution doesn’t work with the -Table Reader- node.

For deleting are you using this node?

image

Thanks
Heather

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.