AI and timeseries extensions dont show up

Hi, I have realized that my Time Series Extension is missing, it seems to be installed but I cant see it on repository and the nodes that I had before seem to be missing as well. I tried uninstall/install the extension, didnt help. I installed Knime from scratch, didnt help either… Then I saw its not only Time Series, AI (within Knime Labs) is missing too.

When I check installation details via Help/About/Installation details, they seem to be installed

can you please help me find the problem and fix it

Hi @hakandurgut,

Welcome back! Could you please share the version of KNIME AP you are using along with your OS details? Just to confirm, were you able to see these nodes before, and they are now missing?

Additionally, can you try dragging this node onto your workspace and let me know what happens?

Best,
Keerthan

2 Likes

Hi, yes I confirm that those nodes were visible and usable before

Knime Version: KNIME 5.2.5

Windows 11 Home
Version: 23H2
OS build: 22635.3785

Processor Intel(R) Core™ i7-10700K CPU @ 3.80GHz 3.79 GHz
RAM: 128 GB

When I drag the chat model Prompter Node onto the canvas I get the following message.

once I click “Yes” button

and pressing “Next”, nothing happens,

when I check the installed software

the extensions are there,

I tried uninstalling the extension, reinstalling, nothing changed

I event installed Knime from scratch, still same.

I also looked at the logs after starting Knime, the error logs seem to be very related to the problem I am having.

knime.log (20.0 KB)

I do not have a regular python installation on the machine, I have anaconda3 only, could this be the problem? I use conda env for various stuff and embedded python for ComfyUI… I will install Python and check it again

I installed Python but didnt help, i found another problem, there was an conda env called “knime” I deleted that, still didnt solve, now I am installing knime from scratch again…

unfortunately, its not resolved, I still get the same errors in the console

after uninstalling anaconda3 and python, the nodes appeared again, so fixed.

could it be because anaconda3 ?

1 Like

Hello @hakandurgut,

If you are still having issues with anaconda3, I would try using Miniconda (a lightweight version of anaconda) just to be on the safe side as it only comes with the necessities.

https://docs.anaconda.com/miniconda/

TL

3 Likes

I did, I went back to miniconda again, no problems, all working, thanks

1 Like