AI extension cannot be installed on KNIME 5.1

I have the same problems installing the ‘Knime AI Extension’ (Community Extensions - Other).

Happy for any hint!

just for info:
on my machine, i had no problems and able to install the extension today, although it was a bit slow on my low internet connection. running knime 5.1 on linux mint 21.2,

rgds

Hello @yupliu and @Erich_Gstrein,

Are you on Windows?
This sounds a lot like problems with long paths on Windows (KNIME Python Integration Guide).
Possible workarounds are

Sorry for your troubles,
Adrian

2 Likes

Hi @nemad, yes I’m on WIN 10 on a company PC (thus some limitations), but the registry field LongPathsEnabled is set to ‘1’.

I just (again) freshly installed/unzipped KNIME 5.1.0 (via zip-archive) and tried to install the Knime AI Extension (see above) as the only additional package. The result is, that after some seconds the installation process gets stuck at 65% when installing the package ‘org.knime.python.llm.channel.bin.win32.x86_64’ (see image). After some time (=minutes) the Error Box pops up showing the message below as the detail:

An error occurred while installing the items

session context was:(profile=KNIMEProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null → [R]org.knime.python.llm.channel.bin.win32.x86_64 5.1.0.202307290225, action=org.knime.product.p2.actions.ShellExec).

ShellExec command exited non-zero exit value:

Screen-Shot:

Hi @nemad , I am on Windows 10 and enabled long paths. I also moved the downloaded zip to c:\tmp.

I got the same error message. I reproduced this on another Desktop I have, thanks!

I am sorry that it was not the long paths.
A failed installation like this should leave an entry in the error log (you can open it via View->Error Log):


If you double-click on the entry that I selected, you should see the log output of the installation process .
Should the error log come up empty, you can also find the logs of the installation create_env.err and create_env.out in the plugin folder located under <knime-installation-dir>\plugins\org.knime.python.llm.channel.bin.win32.x86_64_5.1.0.202307290225\bin.
Hopefully, these logs will give us some more clues.

Best regards,
Adrian

1 Like

Hi Adrian,
attached please find the 'Message’ content copied from the Event Detail window - following your instruction.
As said: Fresh unzipped Knime_5.1.0 installation only installing the ‘Knime AI Extension’ as described above!
Thx
Erich

knime_install_AI_log.txt (47.8 KB)

Same thing here, there are several extensions that can’t be installed, but I was very keen to have the AI extension installed.
image

Extension Installation Failure.log (37.7 KB)

1 Like

Hi all,

@yupliu Thanks for verifying that long path is not the issue. Could you please also provide the three logs as described by Adrian further above? The error log and also the content of create_env.err and create_env.out (see Adrians second post above for where to find these two files). We are trying our best but we need as much information as we can get here :slight_smile:

@Erich_Gstrein Thanks for sharing! Do you have a proxy? Is there a way to double-check whether outside of your company network you have the same issue accessing pip?

@marijakil Thanks for confirming the issue. Could you please verify that you have long paths enabled as Adrian outlined in his first post above? If you confirm that it exists, could you please help us pinning this issue down by also providing create_env.err and create_env.out (see Adrians second post above for where to find these two files)?

We continue looking into this. But as we cannot reproduce it, we need your help guys! :slight_smile:

Thanks
Steffen

1 Like

@steffen_KNIME

I am not sure whether you did something to the installation package or not. After restarting my PC multiple times, I tried to install those plugins again and it worked this time, thanks!

1 Like

Hi Steffen,
yes, in my company’s environment there is a proxy in place - however, this proxy was set in ‘preferences’! Furthermore, working directly with Python/Notebooks on my machine I do not have these pip issues!

And yes, on my private machine - with no proxy - I do not have these issues.

Best
Erich

Same error here, 64bits Knime 5.1, trying to install KNIME AI Extensions (Labs).
log_error.log (520.7 KB)

Thanks @rsalencar,

could you please provide the content of create_env.err and create_env.out (see Adrians second post above to where to find these two files)?

Thanks!
Steffen

@Erich_Gstrein, @steffen_KNIME I think there are currently some problems with Python based nodes and Proxies. They are not always working. There seem to be this workaround of creating a local collection of necessary packages in a KNIME version without a proxy and then transferring this. I have not tried it.

The zipped update packages are of no use. It would be great if the Python based nodes can use the Proxies set. I think I already initiated a ticket (which does not have a number as of yet it seems).

Also for some time now KNIME seems to struggle with recognizing which extensions are already installed and which are not. I have mainly seen this on Apple Silicon but with 5.1 it starts to show on Windows machines too.

@rsalencar I get the same error message even when I set the “KNIME_PYTHON_PACKAGE_REPO_URL” variable and point it to the collected Python packages from another system. From the logfile I can see that the installation sees the local Python packages and then uses them but then stops at the end with some more error messages.

Is there some pattern like
“it does not work on os xyz if python version is abc or if certain dependency incompatibilites show up” or is it completely random?
AI nodes worked for me so I can’t reproduce errors, but I am not completely sure whether i tried them on latest 5.x version
br

Any update on this topic?
thank you

@rsalencar I tried a few more things and was able to get it to work. Had to remove some external references from a pip config file. Details in the grey box in this workflow

@rsalencar
Additionally to @mlauber71 I asked for some input of yours. Maybe you help us first with some information so that we can investigate further? :wink:
Also please tell us whether mlaubers solution worked for you.

Steffen