Are there known reasons why user of the KNIME webportal are logged out while using it?

#1

Hi all,

I get complains of users, that they suddenly are logged out of the KNIME webportal while using it. I could not find any setting which defines a waiting time for a user or something else. Maybe you have an idea whats going on and how to prevent that?

One use case is a JS node we created, where the user has to fill in a lot of metadata. This can easily take up to half an hour or longer to do so and to press NEXT afterwards. This is somehow annoying, since the whole process has to be done again, if the user suddenly gets logged out.

Many thanks,
Lars

0 Likes

#2

Hi @laval,

There are two possibilities that can trigger a logout of a user. An active WebPortal session in the browser sends a heartbeat every 3 minutes to the server. If there is no more hearbeat from the user (e.g. due to closing the browser without manually logging out before), the user will be logged out automatically after 3 minutes. In some browsers hearbeats may be suppressed if the tab is not active.

Another setting is that a user will be logged out if no requests were sent within the last 30 minutes. So if filling the form on your WebPortal page tages longer than 30 minutes, the user will be logged out if no other action (e.g. navigate to next/previous page of WebPortal workflow, start another workflow, etc) was performed by that user in the meantime.

Changing the 30 minute timeout is possible, but not really straight forward. In your webapps\knime\WEB-INF\lib folder of the tomee server you find a jar file named webportal.jar. You’ve got to unzip it, change the timeout setting in src/main/webapp/META-INF/web-fragment.xml and create a jar file from it again. After restarting the server, the new default logout timeout will be used. Bear in mind that these steps have to be repeated in case the server will be updated.

I hope this helps.

Cheers,
Marten

1 Like

closed #3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

0 Likes