ARIMA Learner Always Throw Java heap space Error

Hello Community!

I have fairly new to Knime, and I was playing with the ARIMA extension as I would like to use it to predict sales. I have Microsoft’s AdventureWorkDW2012 Database as my data set. AdventureWorkDW2012 has a table called FactInternetSales which has about 60k Records; it has many columns, however, I only choose:

1- SalesAmount
2- OrderDate

Now I set the ARIMA learner’s Column Containing univariate time serious variable to SalesAmount

and everytime I try to run it, it gives the same error and you should know that I have a 32GB RAM in which 30GB is allocated for knime.

Your help is really appreciated!

It creates matrices with similar size during training for some of the training algorithms, so 60000*60000(*8 bytes) is quite a lot (around 28GB if I am not mistaken). You can try other algorithm (after restart)/parameters, but probably it worth significant downsampling (keeping only most recent few hundred for example or selecting 1% randomly/evenly) first.

Thanks a lot for your reply!

I see, and I tried it; however, it gives same value for all feature values… Anyway, can you please tell me where to find a detailed example about sales forecasting I have been searching for few days now, and I only could find two examples.


I am also getting similar error while executing ARIMA node. I had provided 1GB of Heap size. Still same issue. Is there any pre-requisite to run ARIMA extension.

Hi @alururavindrababu!

Sry for a late response and welcome to the KNIME community!

What error do you get? Where have you assigned 1GB? Memory allocated for KNIME is defined in knime.ini file in installation directory.


1 Like

Dear Ivan, yes in Knime.ini file I have updated. I will place again the error screen shot later.

Thanks and Regards
Ravindra Babu Aluru

1 Like