Association Rule Learner - starting external executable


I’m trying to run the Association Rule Learner node, but it gets stuck at 70% saying “process running for x seconds”. I’ve seen it go up to 2000 seconds.
So it gets stuck on the starting external executable phase. The input data is 1027 records. A while back the exact same flow worked and it had more than 20.000 rows. I looked at the input and it’s exactly the same, data types are the same. I have 16GB memory and 8 cores on my machine.
I use version 3.7 of knime.

Anyone know how to fix this?

Hi @Winanda,

welcome to the KNIME forum!

We would need more information to start debugging the situation. You mention how much RAM does the machine have, but how much is KNIME allowed to use? (check the -Xmx in knime.ini)? Could you also comment on the machine status, when the node gets stuck? In a sense of how much CPU and memory does the knime process use and how much free is available? If you use Windows, you can look this up once the node reaches the stuck state at 70% progress.

Any further information is helpful. For example, if you use public data that you can share with us to try to reproduce your problem (of course do not share private/sensitive data). The same applies for the workflow itself.

Best regards,


Hi Mischa,

Thanks for your response. In the meanwhile I got this issue fixed when I read in some other post that the Association Rule Learner is very sensitive to the minimum support value you enter. I had it on 2%. I was running data about transactions of all our customers. I ran the rule learner for all data on 2% minimum support after that I wanted to run the model for different segments in which we divided our customers. For almost all groups the setting for 2% didn’t work. I was surprised by that because I actually entered less data because I filtered on one group of customers. But apparently it doesn’t depend on the number of rows but on the characteristics of the transaction data. I saw that for customer groups where most of the customers has more than 90 products the settings for minimum support needed to go quite high to limit the number of rules returned. So I played around with the settings for minimum support per group to find the optimal minimum support per group where the rule learner would not get stuck.

So I got the solution by adjusting the minimum support settings. Thanks again for your reply!



This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.