Auto-save bugs

I'm having trouble with the auto-save feature.

I have a workflow that uses a lot of memory and can take some time to run. If auto-save is enabled, and KNIME tries to save the workflow while it is running, it locks up and I have to kill KNIME.

Upon reopening KNIME I find that the auto-saved copy of the workflow is empty.


May I suggest an alternative/additional method of workflow recovery: rather than saving at timed intervals could we please save on-execute? This isn't going to be needed all the time, indeed it would be a bit annoying for quick workflows. Perhaps an additional button for "save and execute all" could be added, or control-clicking could save and then execute. I'm not interested in saving data, but I need to be sure that when I run a big workflow I can kill KNIME, reopen it and try again without having to rebuild.


P.S. Nice work on the new database nodes!


I can second that behaviour. Today, I wanted to use an autosaved workflow only to find that it is empty.

What are we doing wrong? My settings were: Save every 90 seconds, save without data.


Cheers Dennis



I have expereienced this as well.

Any word on what is happening?


I haven't seen this problem before, but it sounds like a pretty serious bug.  

We should try to find out what KNME/Eclipse is doing when KNIME freezes.  

Here is what you need to do:

Sorry for the trouble, hopefully we can get this sorted out quickly. 



The workflow is chugging away at the moment and I don't want to lose the data. When it's done I'll run it again with auto-save turned on and try to catch the error. 

We appreciate it, sorry for the trouble!