Automatic e-mail to workflow connection problem / help does not work correctly.

#1

Hi; I would like to receive an error message as an e-mail error, but it works incorrectly. I didn’t understand where I made a mistake.

I just want the mail to arrive when the error occurs.

@armingrudd

0 Likes

#2

Hi @umutcankurt,

for now your If Switch node is triggered everytime the workflow is executed, and it does not matter whether the upper or lower branch after the If will take place, as both are are followed by a Send Email node. To condition the workflow to send mails only if an error occurs, you’d need to remove the Send Email node from the upper branch of the workflow after the Catch node. (A Catch node will always execute after triggering a Try block, elseway the exception handling will not be complete)

Best,
Alec

2 Likes

#3

The Table Creator (Node 174) is empty.
You have this expression in your Rule Engine Variable:
$${SStatus}$$ = “error” => “bottom”
Add this “error” value to your table creator so in case of error the bottom port of If Switch will work.
Untitled

There is also something else about the configurations of the Get Request node that you may need to consider. With current settings, the node won’t produce an error in case of connection problems or http errors. Maybe it’s better to check the corresponding options:
Untitled

Best,
Armin

2 Likes

#4

Hi; Armin @armingrudd
problem solved. thanks

1 Like

#5

Hi; @Alec
problem solved. thanks

0 Likes

closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

0 Likes