Batch execution changes workspace path

Hello,
I’m trying to execute a workflow (WF_test) in batch mode using this command in a .bat file:

C:\Program Files\KNIME\knime.exe" -nosplash -reset -application org.knime.product.KNIME_BATCH_APPLICATION -workflowDir=“C:\KNIME_REPOSITORY\KnimeBatch\WF_batch\WF_test” -preferences=C:\KNIME_REPOSITORY\preferences.epf -vmargs -Dlog4j.configuration=C:\KNIME_REPOSITORY\log4j3.xml

Worflow is executed and log is produced, but i don’t understand why it changes the workspace’s path to “C:\Users\myname\knime-workspace”
as showed in log:

(this folder doesn’t exists, so it creates this folder and put log there)

while my workspace is set to another directory: C:\KNIME_REPOSITORY.
I tried adding option -data= <workspace_path> to the .bat, but it won’t change anything…

Could someone please help me to understand and fix that?
Thank you
(ps. Sorry, I’m not an expert)

Ema

I think it’s also the reason why if I use relative paths for my tables (knime://…) in the workflow it fails execution: every path is substitute with the wrong path…

“C:\KNIME_REPOSITORY” (right path) is replaced with “C:\Users\myname\knime-workspace”

Seems that I’m not the only one who finds out this issue:

so, this problem is also on Linux.

Hi Ema,

That’s an interesting problem. Sadly I don’t know the answer, but I’m guessing the command line argument -data=<workspace_path> is being overwritten by another config file loaded.

Could you check the knime.ini file for a -data parameter? If its not in there, you could try the preferences.epf you are loading or changing the RECENT_WORKSPACES variable in <knime-install-folder>\configuration\.settings\org.eclipse.ui.ide.prefs (make sure to escape backslashes, colons, etc.). This last change will also affect KNIME when started normally.

Let me know, if any of these work for you :slight_smile:

Kind regards
Marvin

Hi Marvin!

Thank you for your support, I tried the following:

(I changed the name of my workspace form KNIME_REPOSITORY to KNIME_WORKSPACE, same location, so it’s C:\KNIME_WORKSPACE)

  1. I added argument

-data <workspace_path>

to the .ini file in the Knime’s installation directory, under the -vmargs, and re-execute the .bat but it won’t change

  1. the preferences.epf file i use in the .bat
    has not a -data parameter, but i can see this lines:

/configuration/org.eclipse.ui.ide/MAX_RECENT_WORKSPACES=10
/configuration/org.eclipse.ui.ide/RECENT_WORKSPACES=C:\KNIME_WORKSPACE
/configuration/org.eclipse.ui.ide/RECENT_WORKSPACES_PROTOCOL=3
/configuration/org.eclipse.ui.ide/SHOW_RECENT_WORKSPACES=false
/configuration/org.eclipse.ui.ide/SHOW_WORKSPACE_SELECTION_DIALOG=false

  1. file org.eclipse.ui.ide.prefs in the installation direcotry has the following lines:

MAX_RECENT_WORKSPACES=10
RECENT_WORKSPACES=C:\KNIME_WORKSPACE
RECENT_WORKSPACES_PROTOCOL=3
SHOW_RECENT_WORKSPACES=false
SHOW_WORKSPACE_SELECTION_DIALOG=false
eclipse.preferences.version=1

seems that backslashes and columns are correctly excaped (it did automatically).

But it keep creating the folder C:\Users\myname\knime-workspace and using it as workspace…

thank you for any new suggestion

Ema

ps. sorry that escapes are not showed here … but I promise they are in the original file

Thanks for testing all these settings. How peculiar.
What happens when you start KNIME normally (with GUI)? Does that also use the wrong workspace location? If so, you can set it to C:\KNIME_WORKSPACE via File → Switch Workspace → Other…

And just to be sure – your batch file does execute the correct knime.exe, right? Not some other installation elsewhere on your pc.

2 Likes

Hey Marvin,

workflow’s execution from GUI is correct, and when I start Knime normally it uses right workspace (i see also in the knime.workspace variable that path is correct, and relative paths for I/O files also work correctly), I have no other knime installations on my pc (this is the very first installation of Knime on a very new pc with wodows 10) :sleepy:

Hi Ema,

I’m afraid I’m out of ideas.
Maybe its easiest to use the user folder… :smiley:

Kind regards
Marvin

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.