Batch Execution

Hello ,
I am trying to execute a knime wf from command prompt
here is the statement

knime -nosplash -noexit -consoleLog -reset -application org.knime.product.KNIME_BATCH_APPLICATION
-preferences =“D:\Program Files\KNIME\Exported.Knime.Preferences.epf”

i’ve also tried

" D:\Program Files\KNIME\knime.exe" -nosplash -noexit -consoleLog -reset -application org.knime.product.KNIME_BATCH_APPLICATION
-preferences ="D:\Program Files\KNIME\Exported.Knime.Preferences.epf

and changed the order of preferences and workflowdir

the error is workflow directory is not given
can anyone please help by telling me what is the correct statement?


Please provide a screenshot of your CMD or Powershell window featuring the command being executed; also before the command due a directory listing of the items specified by workflowDir and preferences.

Please also provide a screen shot of, or copy and paste from, the KNIME console window that opens.

Here is the screenshot.
Please let me know how can i write the command ?

That’s one of the two screenshots i asked for. In addition to providing the first screenshot, please ensure that your desktop KNIME application (and no other KNIME application which is using this workspace) is running at the same time you attempt to run in batch mode.

This is the command

knime -nosplash -noexit -consoleLog -reset -application org.knime.product.KNIME_BATCH_APPLICATION
-preferences =“D:\Program Files\KNIME\Exported.Knime.Preferences.epf”

Yeah no other application is running.
It is on server

Thanks ,

Hmmm… as you can see in that CMD window, you are pasting three commands - this should be one single command. (ie.:

knime -nosplash -noexit -consoleLog -reset -application org.knime.product.KNIME_BATCH_APPLICATION -workflowDir=“C:\my-workspace\my-workflow” -preferences =“C:\my-stuff\knime_prefs.epf”


1 Like

Thanks @quaeler
I dont see that error now.
But i see this error , says preferences canoot be parsed

Sorry - there was a space after the -preferences argument and before its following = which should not be there - like it is not with -workflowDir


Thanks @quaeler
It worked.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.