Batch mode/cmd shows error KNIME 4.4


I hope you can help me with this, I’ve tried uninstalling/reinstalling KNIME 4.4 to 4.3 back to 4.4 again to see it helps but to no avail.

I tried to run my this through .cmd and .bat files

“C:\Program Files\KNIME\knime.exe” -noexit -consoleLog -nosplash -reset -application org.knime.product.KNIME_BATCH_APPLICATION -workflowDir=“C:\Users\ana\knime-workspace\xx\xx”

and I don’t think something’s wrong with the above because I was able to run workflows like that.
Recently, when I installed 4.4, it returns below and it doesn’t show any sign of finishing (example, not saying = 4 or = 3). I also installed Expressions nodes and I’m very suspicious they might be the reason why I have these error but I don’t really know.


Hi @Ana914 , looking at your screenshot, I don’t see any errors. Can you please highlight which error messages you are seeing?

Hi Bruno,

Sorry I termed it error - I think there’s something wrong so I called it error. Number 1 is that warning about Nashorn and an execution that doesn’t seem to end. Number 2 is that I never get a status afterwards if it’s completed or not. I tried to leave it for an hour or two and it never shows if it’s completed or not (that small window where i should see = 4 or =3 never shows up). Basically, running batch mode for me is not working. I hope you can help, I don’t know what to do.

my workflow is also just a very simple ETL but with constant value column taken from Expressions Node extension.

Hi @Ana914 , looking at your workflow, I don’t see where there is any issue. It should be able to run properly, but obviously not see the configurations of the notes, I can’t tell 100%. Does the workflow run properly via Knime UI?

Regarding the warning, it just means that the Nashorn engine will be deprecated, so you might have an issue in the future when you upgrade your java. I think you start getting this warning from Java 11, and it seems like the Nashorn engine is removed from Java 15.

It should not be an issue in your current environment, you can ignore these warnings.

Thanks, Bruno :slight_smile:

There is no issue indeed when I run it through KNIME UI. I think my problem 1 is solved about the Nashorn engine warnings - thank you.

I just need to figure out why it doesn’t finish or complete the run. I don’t see status of the execution to know if it’s successful or not.

I also run it as “.cmd” if that makes a difference.

Hi @Ana914 , running as .cmd should not be a problem. It’s easy to test this by running the command on the command prompt.

As I said, I don’t see any issue with your workflow, and you also confirmed that the workflow runs via the Knime UI.

I can’t play around with this as unfortunately I’m not on Knime v4.4 yet. May be someone who has more experience with v4.4 can chime in.

Hi Bruno,

Finally got it – and it’s a bit facepalm…i just removed “-no exit” in my parameters and started from there :slight_smile:

Thanks for your time and reply to this though! Appreciate it

Hi @Ana914 lol :rofl:. Hey, at least you figured it out :slight_smile:

I assumed, though, that you checked that the operation was completed by verifying that the csv and excel files where created, and not just by looking at the cmd screen :smiley:

Did the files not get created when you had the --noexit option?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.