Batch mode on linux

test some command on linux,have some questions,
use case 1
knime -noexit -nosplash -nosave -reset -application org.knime.product.KNIME_BATCH_APPLICATION -workflowFile=maindata.knwf

the workflow execute in the path start with /tmp/BatchExecutorInput after workflow execute success,the folder is deleted.In my workflow will export csv file to relative path(knime://knime.workflow). ,in this case, the csv file locate in /tmp/BatchExecutorInput ,after workflow run success the csv file is deleted.

use case 2
knime -noexit -nosplash -nosave -reset -application org.knime.product.KNIME_BATCH_APPLICATION -workflowFile=maindata.knwf -destDir=/data/loujianwen/model

I thought the -destDir option will tell knime execute workflow in the destDir,so export csv file will located in the destDir and will not be deleted,but result is not ,the workflow still workflow in the path start with /tmp/BatchExecutorInput

my question
1、how can i set the workflow execute in the destDir and not delete the destDir,i need to upload export file to HDFS?

Hi @lou,

Use -workflowDir instead of -workflowFile. E.g.:
knime -noexit -nosplash -nosave -reset -application org.knime.product.KNIME_BATCH_APPLICATION -workflowDir="<path to the workspace>/workflow"

:blush:

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.