batch mode only: Cannot determine major version of R

Hi everyone,

when I run an R node in batch mode, Knime tells me it cannot determine the major version of R. The same workflow runs fine in the GUI. The R preferences page shows no errors, either.

Any hints what might go wrong here?

Versions are Knime 3.2.1 (console says 3.2.2) and R 3.2.2.

 

Best,

Lorenz

When I try to debug it, I get up to the line in the source code where RbinUtils queries the R preferences (and version), but of that Class, the IDE does not find the source code (not sure why, that worked for me in 3.1).

Didn't try it with the IDE yet, but how would I set the batch log level to DEBUG? If I remember correctly, that should contain the necessary information, too.

Ok, I guess I could solve the problem for now. The "-preferences" argument also sets the R Home, which is fine. Two questions remain though:

  • how can I set the batch log level to DEBUG
  • does the -preferences argument still overwrite the preference files? And if so, which ones?

The log level is also controlled via the preferences. Additionally you can edit the log4j.xml in <workspace>/.metadata/knime.

-preferences reads the preferences and applies to the to the current instance. It doesn't overwrite any other preference files.