BCUT no output

With 2.6.3 with latest cdk update that corrected pubchem fp issue, bcut, charged Partial surface area in properties node shows no result.

Thanks in advance

On linux 64 bit distro, knime 2.6.3, multiple Smiles read using file reader and cast are not converted to cdk molecule. Conversion to sdf using marvin does not help. Works on windows for same versions.

3D conversion does not work on both OS's. Kindly make sure that the pubchem issue reported earlier and these are tested and debugged on 2.7 on different os's as well.

 

thanks

Hi,

thanks for the bug reports. 

1) BCUT: Fixed, the input parameter requirements had changed. Tests added.

2) CPSA: The descriptor works only on 3D molecules. Have you used molecules with 2D coordinates instead? In any case, I have added a "(3D)" tag behind the descriptor name. Eventually that property should be moved to the 3D section.

3) Linux / Mac: I will test the plug-in on Linux (Ubuntu/Fedora) and Mac first thing next week.

I have updated the nightly build.

Stephan

I tried using the 2d->3d cdk convertor which does not seem to work even for simple molecules. Did not input 3d sdf by . The timeout for 3d conversion is the default.

Hi,

I tested the plug-in on Mac and Linux and it works fine now.

The 3D convertor was properly broken but works again. It still fails to convert many molecules though ...

Re Smiles: The parser still worked with SMILES that were wrapped in a SMILES cell but Strings were assumed to be InChI. The parser will now check if input strings are InChI or not and use the correct parser. I added some comments in the node description.

I updated the nightly build. If it prooves stable, the 2.6 / 2.7 release follow soon.

Cheers

Stephan