Blocks and links missing....

Hi, I´m new in the forum so sorry if I’m doing something wrong. I have been looking in the forum for an issue that I’m suffering in different Knime workflows, but I haven´t be able to achieved it so sorry again if I´m redundant.

I have some workflows for automate tasks involving data bases, excel books etc… I run the workflows in batch mode using command line options in a .bat file. I run the .bat files using the windows task manager.

Sometimes the tasks don´t execute ok, and when I open the workflow to check it, I find that a block, a link or both are missing. Can anybody help me with this?

Thank you.


welcome to the KNIME Forum. The error you are describing is really odd and seems to be quite unusual. At least from my experience (so you shouldn’t mind that you asked :wink: )
Can you answer the following question in order to make it easier to understand your problem.
1.) How much data do you process with your workflow (size in terms of memory usage).
2.) What configurations did you use in your .bat file (e.g. -nosave yes or no?)
3.) Does your workflow fail every time you execute it or not? If not, any ideas what might be different on the days where the workflow fails?
4.) Check the KNIME log file (workspace > .metadata > knime.log) and post it here if possible.
5.) How much memory do you assign to KNIME (see knime.ini -Xmx xxx setting)

The only time i experienced the loss of nodes or connections was when KNIME was processing too much data (too much to keep in memory at least) and workflow auto save option (with data) was switched on.

Thank you very much for your answer. In a first reading, I can see some keys that could be related to my problem. Now, I will try to answer your questions:

1.- I´m not sure what can I do to give you this data. I have executed de workflow wich often report me the problem and I have checked im windows resource monitor de memory assigned and the memory in the work space: 2.694.260 KB the firt and 2.273.536 KB the second.

2.- Here is an example:
“C:\Program Files\KNIME\knime.exe” -consoleLog -noexit -nosplash -application org.knime.product.KNIME_BATCH_APPLICATION -workflowDir=“C:\Users\Eurocontrol\knime-workspace\PRODUCCION_SEMANAL_4” -reset --launcher.suppressErrors

3.- No, the work flow fails eventually. There is not a known pattern between fails.

4.- Let me know if the file is this:
5.- 4g (I have 8Gb RAM Installed but I´m using the pc when the workflow run with different applications running. I changed this parameter by myself a long time ago, waiting for a solution.)

Thank you very much again and let me know if yo need something more.



I’m having a similar issue to this (running workflows using command line) and I found my workflows with Excel files as a source (Excel Reader node) are not running. I’ve tried copying text out of the Excel file and pasting into a Table Creator node, and my workflow runs just fine using Task Scheduler.

Although this works, I’d like to use Excel as a source so the spreadsheet can be updated and incorporated into the workflow. I’m wondering if anyone has seen this issue when executing workflows using bat file and task scheduler.


I was testing some things out with this and here is what I found:

  • Excel Reader (XLS) node does not execute in batch mode when executed via Task Scheduler
  • File Reader node does not execute in batch mode when executed via Task Scheduler
  • Table Creator does execute in batch mode when executed via Task Scheduler
  • Google Sheets does execute in batch mode when executed via Task Scheduler

I ended up creating the file as a Google Sheet and connecting the workflow that way. If anyone knows why the File Reader and Excel Reader do not work, I’m curious to know.


Maybe you could tell us more about your excel and presumably CSV/txt file or even provide a sample.

Does the excel reader execute in ‘normal’ KNIME mode? Without batch?

Maybe you could provide an example that does fail so one could investigate further.