bug? can't change a template node's link type if it is inside a metanode or wrapped metanode

Don't know if this is a bug, but it seems you can't change a template node's link type if the termplate node is already inside a metanode or a wrapped metanode. You can only change it if it is in the main workflow. 

Luckily you can still copy it after changing the link type in the main workflow into a metanode, and the modified link type will stay modified.

David

 

Hi David,

I tried to reconstruct this but I failed. 

 

What I did is, I had a linked wrapped node on my top level. And this one I wrapped into another wrapped node. But I still can change the link type... I tried the same with metanodes, but it was also working as expected.

Could you give me a description how to reconstruct this?

Thank you!

Iris 

thanks for trying along, I'll set up an example and see if you see the same. Sorry for missing your reply earlier, have been really tied up. 

Best

David

 

Hi, 

I came across an issue that looks similar.

Attached repro contains a tempate-node and workflow.

In the workflow when the template is used in the main workflow, I can update the link type to be saved as relative link.

But inside a metanode I cannot update the link-type. The linked metanode 4:4 is never updated to contain a relative link.

Thanks.

 

Hi David,

just wanted to let you know, that we fixed this with 3.3.1

Best, Iris

Hi Barb,

 

yes this sounds like the same problem.

We just released 3.3.1 were we fixed this problem. Could you try using 3.3.1 and tell me if your problem still  exists?

 

Thank you ! Iris

Thanks for coming back on this. I'm on using 3.2.2 for now as 3.3.1 has a problem with the java external libraries. But when that's sorted I'll have a look.

is it possible to set alerts to get an emai when a comment is posted onto one's own content?

David

 

Unfortunately not. But you can use your track https://tech.knime.org/users/david-ko/track

And threads with new posts will be marked as new, until you have opened them.

 

Iris