Bug in Histogram node HiLiting


There seems to be a bug in the Histogram node. This can be replicated with two string columns which have a small number of common classes/bins in each (i.e. Molecular Weight binned into 4 bins, and LogP binned into 4 bins)

If you take one of these class columns and undertake a One2Many on this so you have these bins now as separate columns with the rows represented as 0 or 1.

Now if you use the Histogram node, and Bin by the remaining String column and Aggregate on the resultant One2Many columns, choosing Sum as the aggregation method, you have a nice bar graph showing the distribution of one property in the various bins of the other property.

I have now selected a single bar on this graph by clicking on it, and chose HiLite from the menu, however it then seems to HiLite multiple bars and in a resultant Interactive Table Viewer node I have set up to display HiLited rows only, there are far more results in the Interactive Table Viewer than whats represented in the single bar I highlighted.

Any idea whats going on.


Hi Simon, 

Hilighting won't quite work like that because the aggregation method is looking at all rows, not just the ones with a value of 1.  

However, if you ditch the one2many and use groupby instead, you can get this to work.  See the attached example for details, but basically you turn on hilighting in the groupby node, then aggregate on both columns, counting rows of each class.  Next, you can color your grouped table according to your 2nd nominal value column, and subsequently create a histogram based on the first one.  

In the histogram, you can now select the "sum" aggregation method for your counts, and you should see each subroup represnented, but stacked vertically.  If you prefer horizontal stacking, you can change this preference in the Visualization Settings tab along with a few other small attributes.  

Have a look and post back if this works for you. 




Hi Aaron,

many thanks, I understand your point. The groupby method you attach works much better. Thanks for the detail and time you provided.