Bug in Release 3.4.1 Row Splitter

Just wanted to let people know I have stumbled across a bug in the row splitter (Manipulation->Row->Filter->Row Splitter) in release 3.4.1.

The regular expression option is non functional. (See the attached image of the configuration dialog for settings). No matter what kind of regular expression you put in, no filtering takes place. As you can see the filter I wanted to use was nothing tricky. I tried single and double quotes, using a single string (no 'or' operator) and it absolutely refused to filter any data. When I uncheck the regular expression option, it performs as you would expect. string matches, wildcards, etc. all work. But check the regular expression box and it stops filtering altogether. No error messages or other misbehavior, it just doesn't filter anything.

Easy work around, just use plain string matches, and avoid the regular expression option.

No response needed, just wanted to let people know.

BTW, I am running Windows 10 Enterprise OS if that matters.

Cheers,

Vance

Dear Vance,

I know you said no response needed, but I just wanted to say I can't reproduce the issue you mention...  I am also on KNIME 3.4.1 on Windows 10, and I find regex to work as expected in the Row Splitter node.

It could be useful to see an example of the addresses you are filtering(?).  If they are simply single word addresses such as "cambia" or "regence", then I would expect your Row Splitter node to work as setup in the image you attached.  If this is the case then it seems you definitely have a problem with your KNIME installation!

However, if the address entries are more complex than this, then the regex would need some work - the following would match any entry that had either "cambia" or "regence" somewhere in the address:

 

.*(cambia|regence).*

 

Kind regards

James