[BUG] Pivoting node: Include missing values not working

The pivoting node does not include missing values. In addition, unchecking missing, the node doesn’t save that but actually keeps missing checked. Tested with several aggregation methods.

Attached a workflow to demonstrate that there should be 62.097 Rows but after pivoting it’s significant less as the column “RowID” which got missing values are not present. Splitting rows double verifies the issue.

190130 Pivoting Missing ingnored.knwf (16.4 KB)

Sample_data.csv.gz.zip (281.7 KB)

Hi there!

I have checked your workflow and don’t think this is a bug.

In Pivoting node in Settings tab there are two options regarding missing values. The first one is on Pivots tab (for pivoting column) and the second one on Manual Aggregation tab (one for each aggregation method). In your workflow (and by default) the option for pivoting column Ignore missing values is checked so that is the reason you are not getting the same number of rows as it ignores rows containing missing values in your pivot column (split_0).

Option missing on Manual aggregation tab is associated with column chosen for Aggregation method. In your case split_1. Hope this clarifies missing values in Pivoting node :slight_smile:

Tnx for engaging!

Have a nice day,
Ivan

2 Likes