[Bug] Pivots removes characters from column names

Hi there,

as far as I can comprehend the Pivot Node is removing characters form the column names. Though, I am struggling to recognize the pattern here … look for “additional_videos” vs. “additional_video” (missing s at the en).


Hi @mw,

The “addtional_video” in the first part of the last 3 column names is a “Type” column value not a column name.
You have used the “Type” column as the pivoting column so the values inside this column come as pivot names and then the column names for aggregation column go after the plus (+) sign.


1 Like

But even though it’s a type, the name should remain the same, shouldn’t it?

Check the values inside “Type” column. You have 3 different values there. One of them is “additional_video”. When you pivot the table and choose “pivot name+aggregation name”, the values inside the pivoting column are the pivot names which go at first and then aggregation name depends on what you have chosen in the next option “aggregation name” which in your case is the original column name.

So unless you have “additional_videos” not “additional_video” as a value inside “Type” column, everything is as expected here.



:exploding_head: … my head got in a dead end focussing on additional_images instead of video. My bad. Thanks for the little head bump.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.