Bug when opening a Column Renamer or Column Name Extractor after Knime update 5.2.3.

Hi all,

Last week I downloaded KNIME update 5.2.3. and since then I have problems configuring the nodes “Column Renamer” and “Column Name Extractor”.

If I choose the option to configure the nodes, instead of opening the configuration settings it opens my own Files on my computer. It tries to Save As the node with file name “apWrapper”.

Hopefully someone recognizes this problem and can help me solve this!

Hello @JanneBel ,
Welcome to the KNIME Community!
Thank you for reporting this. Though I could not reproduce the issue, I will ask about this internally and get back to you.

Thanks,
Sanket

2 Likes

Hi @JanneBel,

it seems to be a rare problem we haven’t seen so far and aren’t able to reproduce on our end. We have a hypothesis but aren’t able to verify that.

Some basic questions:

  • what’s the operation system you’re using?
  • is it a problem for other nodes, too (e.g. Column Filter) or only the two you mentioned?
  • is there anything suspicious in the logs? <workspace>/.metadata/knime/knime.log or <workspace>/.metadata/.log
  • does the problem persist if you try a fresh installation? (if you haven’t tried that already)

Would you also be able/willing to dig a bit deeper by following these steps below?

  • add -Dorg.knime.ui.dev.mode=true to your knime.ini
  • start the AP and a open a problematic dialog
  • open localhost:8888 in your browser
  • click on the “KNIME PageBuilder” link
  • open the ‘Console’ tab and take a screenshot (and share it here)
  • open the ‘Network’ tab, hit F5 to refresh and take a screenshot (and share it here)
  • anything else in logs now? (because org.knime.ui.dev.mode enabled some additional logging)
3 Likes

Hi Hornm,

I have tried to uninstall the KNIME program and installed it again and now the issue is solved!

So, happy that it all worked out again. If the issue arises again I will walk through the steps you wrote down.

Thank you!

King regards,
Janne

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.