Call Workflow Service - locally and server

Hi!

Is there a way of using the Call Workflow Service flexibly in both local environment and the server? When run on the server, the node doesn’t require any connectors, but without them it won’t run locally. I tried to use credentials and tick the option of using server logins when run on the server, but it doesn’t seem to work.
image

Hi @pzkor,

next to the credentials Widget (which will show a user/pw input in the WebPortal), the Credentials Configuration node may be an option.

However, if you use the default Mount ID chosen by your KNIME Administrator (which is quite likely), you can likely use the KNIME Mountpoint Connector, replacing the KNIME Server Connector and Credentials. The only caveat is that you need to be logged in to the Server when using it.

Kind regards
Marvin

1 Like

Thanks Marvin.

The Call Workflow Service node doesn’t like the KNIME Mountpoint Connector

How odd; what KNIME version are you using?
In my case I was able to call workflows on the server, no matter whether the calling workflow was local or on the server itself.

I am using Desktop 4.5.2

Hi @pzkor,

I’ve just tried with 4.5.2 and ran into the same issue. It seems this feature is only supported since 4.6.

At least that gives us something to look forward to. For now, we seem to be stuck with Credentials Configuration nodes and/or workarounds until you can and want to update. Or maybe someone else has other smart ideas? :slight_smile:

Kind regards
Marvin

1 Like