can not import workflow

dear All,

ı am using Knime 3.5.3 version for 3 months.
but today ı cannot import workflows from workspace directory. System gives me error.
how can ı proceed?

Hi @hadi,

Can you describe the steps you are taking to import the workflows?
Also what error are you getting?
What operating system are you using?


Dear Cpadilla,
thank you for your response first of all.

I made many workflows and saved to my workspace.
yesterday first ı lost my workflows of local workspace from the knime explorer. ı can not see them.
I import workflows and select directory.I can see all my saved nodes and directory at the workspace.but ı can not see any .knwf files.
when ı try to import workflows from other directory I took error.
ı recevied error like Error during import and it is written that zip file closed at the details.

I use windows 7.

ı can see EXAMPLES from Knime community and import.

I tried to uninstall Knime and reinstall.but it did not work.
I still cannot reach my 3 months study, workflows.

You have basically two types of data:

  • folders and files that form a knime workspace and you can just point KNIME to that folder. If your files are still intact KNIME should just use them *1)
  • you can pack a single workflow or a group of workflows into a single file (it used to be .zip now it is *knar and *knwf). Here you have your compressed workflows *2)
  • with the import you can either import from such a file or you can point to a directory and import that *3)

KNIME consist of many single files, xmld, zips and so on *4). So it makes sense to keep them somewhere save and have a backup ready in the form of Dropbox ore Onedrive and export your work on a regular basis.

And you should make sure that your file system can handle special characters like Hashtag #. I have seen cases where eg Onedrive had serious limitations in that regard and was effectively destroying KNIME workflows.




*4) this is a single KNIME workflow how it looks on a file system

1 Like

I changed workspace folder. then I copied old folders to new workspace folder.
It worked and succeeded to open workflows

thank you for your efforts.