Cannot deploy workflow to Knime Server

Hi, I am just doing a simple thing, e.g. deploying a workflow from local to server.

I get this error:
An internal error occurred during: “Upload of proyek1 to knime-server2:/tests/proyek1”.
java.io.IOException: Server returned HTTP response code: 500 for URL: http://knimes.lsa:8080/knime/rest/v4/repository/tests/proyek1:data

Any idea what is happening? I can access the server okay.
I tried both drag and drop or deploy method, cannot.

I tried changing whatever workflow that is already there. cannot - pretty much the same error.

Creating new workflow group works.

Thanks!
Mizu-

Hi Mizu,

I think you’ll need to get the server logs from the server admin (that can be most easily done via the WebPortal).

The logs should give you a good idea of what is happening, but if not please drop me a DM with the log files and I’ll take a look at them for you.

Best,

Jon

Hello Team

same error am facing… any update on this ??

Hi,

as Jon has already pointed out, it is not possible to proceed without seeing server logs. Do you mind sharing them?

Cheers,
Mischa

catalina.2019-09-25.log (3.3 KB)

localhost.2019-09-25.log (817.8 KB)

https://drive.google.com/open?id=1huFdl-WNNLn57W9On7E-PK1O_dj_DLCj

https://drive.google.com/open?id=1huFdl-WNNLn57W9On7E-PK1O_dj_DLCj

Hi,

what time did you see the error? Could you please double-check that the incident happened on the date for which you send logs files? Could you please also provide the executor logs? And I was not able to get content from the gdrive links. Could you please make them public?

Cheers,
Mischa

Same error, but only happens on macos. In my windows machine all is fine. Log says: "Upload of /Users/nael/01. Importing Data " did not contain any files or directories.

My Knime server version is 4.10 and the platform version is 4.1

Hi,

did you get any error in your KNIME Analytics Platform?
Could you share your knime.log and the server’s log?
Could you check the server address of both machines (check if both end with /knime/rest or if one of these ends with /tomee/ejb). You simply have to check the address behind the mount ids in your KNIME Explorer:

Cheers,
Moritz

Hi,

solve it, our proxy setup was falsy.
Thank you very much.

Best regards, Nael

3 Likes