Cannot load libraries

Hi all,

the problem in subject is known from Knime 2.3.0 (64bit) has not been fixed in 2.3.1

Any news?

Best

-andrea

Hi Andrea,

There are still no 64bit Windows libraries for RDKit. Greg is working on them but is currently busy travelling around the globe.

Cheers,

Thorsten

Along those lines I noticed that the nightly build for 64bit linux is broken (the stable works fine). The version numbers are:

RDKit binaries: 1.0.0.0000726
RDKit KNIME integration: 1.0.0.0000743

32bit Linux does not have these problem. Can you confirm?

There is difference in the underlying library. The one from nightly seems to have more strong OS dependencies:

Caused by: java.lang.UnsatisfiedLinkError: /local_tmp/wiswedel/knime_2.3.1/plugins/org.rdkit.knime.bin.linux.x86_64_1.0.0.0000725/os/linux
/x86_64/libRDKFuncs.so: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /local_tmp/wiswedel/knime_2.3.1/plugins
/org.rdkit.knime.bin.linux.x86_64_1.0.0.0000725/os/linux/x86_64/libRDKFuncs.so)


If I uninstall the nightly an re-install the stable release, it's working again.