Cannot read KNIME tables from the Server (in the portal)

Hi all,
I have a few KNIME tables in our server that I want to use in workflows to be deployed in the Server. When I build the workflow in the Data Analytics Platform, the Table Reader works well and I can see the data. When I deploy the workflow in the server and try to execute it via the portal, the Table Reader cannot read the table (it says connection refused). I tried to use the Absolute Path, Mountpoint and even workflow relative path. All without success.

Error

Any ideas on what might be happening? Funny enough I was able to do this in the past (a couple of weeks ago), I am not area that anything has changed.

I am confused.
Why don’t you have a workflow variable output on the component on the left?
Try it that way (add a workflow variable output to the component) and make sure you “let the variable out” of the component.

Maybe that helps.

Hi,
Let me clarify. In this part of the workflow especifically, the content of the table is input in a variable to be displayed in a message in the portal (that is why the Text Output Widget). There is no use for that variable further on.

But in any case, the issue is that the Table Reader does not work. Even if I create a workflow where I just drag and drop a table file from the server, whenever the workflow is deployed it does no run.

Error

Hi,

ok, if even drag and drop does not work, then it should not be because the the variable.

I had a similiar problem once - it was a permission issue.
The table was in a folder that the consumer was not allowed to access.

Maybe it’s that?
If not, then you probably have to wait for a knimer to support you.

best regards

Do you happen to have SSL set up on the server?

Also, are you able to share the workflow and node connection info with us so that we can take a look to see if anything looks off in the configuration?

@ztrubow, thanks for helping. We are checking now with a closer support form Marten. It still not clear what the issue is, but I will post it here once we figure it out.