Can't connect to my KNIME hub from KNIME explore

I am new KNIME user. I am having problem with connecting to
my KNIME hub from the explore window. When double click on to connect it
always show a pop up window saying “Login to ‘My-KNIME-Hub’: A new tab has
been opened in your browser” and there are two options “Cancel” and “Retry”.
Then it will just stay there and won’t let me connect to the hub. Can you
please let me know how to fix it? Thank you.

Hello @ycao0472,

and welcome to KNIME Community!

Can you access EXAMPLES server (also done from KNIME Explorer)? Have you tried logging into KNIME Hub from browser? Does that work?


Hi, Ivan

I can connect to Example server and can log into the KNIME hub from web browser.

This is how I found out the issue with connecting to the hub from the KNIME explore. I was taking the self paced training for the level I exam and couldn’t download the workflows from the hub and I had to download those workflows and solutions from the KNIME hub website to my local drive and do the exercises.

Just to be clear, I can access Examples server from KNIME explore.

Thanks. Bill

Hello @ycao0472,

ok. I see. Tnx for additional information. You should look into your log file to find more information. File can be found on following location: ...\knime-workspace\.metadata\knime
Just before you do that make sure to go to preferences and set log level to DEBUG to get higher log verbosity (File --> Preferences --> KNIME).


Hi Ivan

below is the log when I tried to log in the KNIME Hub. Could you please take a look and advise what the issue could be?

FYI. I set the log to debut mode.



2020-12-04 15:02:34,504 : DEBUG : main : : WorkflowMetaView : : : Received unexpected file info type: class org.knime.workbench.explorer.filesystem.MessageFileInfo
2020-12-04 15:02:35,130 : DEBUG : Thread-47 : : OAuthAuthenticator : : : Login to ‘’.
2020-12-04 15:02:35,131 : INFO : Thread-47 : : OAuthAuthenticator : : : Opening browser to perform authentication for ‘’.

Hello @ycao0472,

hmm… Nothing after it? What browser are you using? Do you maybe have some kind of restrictions that forbid this kind of authentication?


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.