cant open workflow - error

java.lang.IllegalAccessError: tried to access method org.knime.core.node.workflow.WorkflowContext$Factory.(Lorg/knime/core/node/workflow/WorkflowContext;)V from class org.knime.core.node.workflow.WorkflowManager

I am unable to open the workflow in knime AP
am using knime on AWS ubuntu 18.4

knime Ap3.7 server 4.8.2

I updated some extensions from the moment I face this problem…

Do you know what extensions you updated? (The error message hints to that you have mixed versions of KNIME libraries installed - and that a class from an older one is attempting to talk to a class from a newer one (or vice versa.))

no… i dont know which i updated… i updated 4.X on 3.7… after that only problem start…

I would install a clean version of 4.x (and in general always install a fresh version when changing major versions (e.g 2.x -> 3.x, 3.x -> 4.x, etc.))

2 Likes

Update from 3.7 to 4.0 is not supported. One must install 4.0 with a fresh install.

Best,
Mischa.

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.