Can't register oracle jdbc driver on macos.

I am trying to register an oracle jdbc driver for the new database nodes in 4.0, but can’t get passed the “Find driver classes” step.

These same drivers, ojdbc6.jar, ojdbc7.jar, ojdbc8.jar, all work on the Linux/Win version of KNIME. I’m following this procedure:

When I try to set the driver class, pressing the button flashes up a message very briefly (I think it says “Operation in progress…”), but the drop down menu is never filled with any selection like it is on Linux/Win.

I’ve tried reinstalling KNIME 4, a clean install of KNIME 4 with only the default extensions, but nothing seems to work.

I’ve given KNIME 4 “full disk access” in the securities preference. The drivers have their +x permission set.

If I revert to KNIME 3.7.2, the jdbc drivers can be registered.

KNIME: 4.0.0.v201906261003
Macos: 10.14.6
Java: OpenJDK Runtime Environment AdoptOpenJDK (build 11.0.4+11)

Not sure what to try next.

Log files in debug mode available if needed.


Hi Simon,
I’m sorry to hear that you have a problem with the driver registry. Unfortunately we couldn’t reproduce the problem with one of our Macs with Macos 10.14.3. In general KNIME runs with Java 8 so we suggest to use the ojdbc8.jar for KNIME.
I will contact you via personal message so that you can send me the log files.

Solution: After a lot of back and forth, Tobias worked out that an errant driver placed in /Library/Java/Extensions years ago was causing the problem. Old driver removed, and new ones now register correctly.
Thanks again Tobias,


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.