Can't run KNIME workflow via batch mode on windows

Dear all,
I have tried to invoke knime workflow

knime.exe -consoleLog -noexit -nosplash -application org.knime.product.KNIME_BATCH_APPLICATION

knime -nosplash -application org.knime.product.KNIME_BATCH_APPLICATION -workflowDir=“workspace/test”

But in the end I got this error information.

Please help me!

1 Like

Hi @hellomingxing -

Exit code 2 occurs if parameters are wrong or missing. So the problem might be that you have some workflow variables that you need to provide values for.

The other thing I noticed is that you are using the -workflowDir option. This option should point to a directory rather than a zip file… if you want to point to a zip file, use the -workflowFile option.

Does that help?

Hey @hellomingxing,

your workflowDir parm is in error. It took me 6 hrs to get this running under windows.
See my example below:

knime.exe -consoleLog -nosplash -reset -application org.knime.product.KNIME_BATCH_APPLICATION -workflowDir=“c:/Users/pfindeis/knime-workspace/YourWorkflow/”

Apparently, you need to adapt the complete workflowDir parm to your environment. Please note that the path is with slashes (/), not backslashes ()!

See this forum thread for more infos: KNIME and batch mode

Let me know if this was helpful.

Kind regards,


1 Like

It looks like your question has been answered in your other thread. Let’s continue the discussion there: