Can't update or install any extension

Hi,

I am using OSx 10.11.2, and I am new in knime. I just downloaded version 3.1.1, but I had knime 2.12 at the same time and I tried to install both together as I had a probelm with indigo extension. Now, I removed knime 2.12, and installed 3.1.1. The problem is everytime I try to update or add extension it gives me the following persmission message as following:

Your KNIME installation directory seems to be read-only, maybe because KNIME was installed by a different user. Installing extensions or updating KNIME may cause problems. Do you really want to continue?

and when I continue the installation fails by giving the following error message:

An error occurred while uninstalling session context was:(profile=KNIMEProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Uninstall, operand=[R]org.knime.product.desktop_root 3.1.1.v201601291159 --> null, action=org.eclipse.equinox.internal.p2.touchpoint.natives.actions.CleanupzipAction).

Backup of file /Volumes/KNIME 3.1.1/KNIME 3.1.1.app/Contents/Eclipse/quickstart.pdf failed.

File that was copied to backup could not be deleted: /Volumes/KNIME 3.1.1/KNIME 3.1.1.app/Contents/Eclipse/quickstart.pdf

The only thing that I changed is the directory during installation.

Can you help?

Thanks!

Well first thing that comes up to me is:

- Do you have administrator rights from the account you are trying to update KNIME?

Yes I do! I am the only user and it should be installed on my user only. I also made sure that the log folder (which I have changed during installation) is permitted for read and write.

It looks like you are starting KNIME from the downloaded image ("/Volumes/KNIME 3.1.1"). The image is read-only, therefore you cannot make any changes to it. You have copy the application into your "Applications" folder first and then use it from there.

Yah! Thanks Thor! That was fixed then, but now I am encountring another problem, which is when I am trying to install the chemoinfromatics and bioinfromatics extension from the community (nightly and trusted) I always get the following message:

Cannot complete the install because one or more required items could not be found.
  Software being installed: OpenMS 2.0.0.201603071909 (de.openms.feature.feature.group 2.0.0.201603071909)
  Missing requirement: EMF Ecore 2.11.0.v20150512-0501 (org.eclipse.emf.ecore 2.11.0.v20150512-0501) requires 'package javax.crypto 0.0.0' but it could not be found
  Cannot satisfy dependency:
    From: OpenMS 2.0.0.201603071909 (de.openms.feature.feature.group 2.0.0.201603071909)
    To: de.openms.knime.startupCheck [1.10.0.201602200020]
  Cannot satisfy dependency:
    From: OpenMS System Requirements Check 1.10.0.201602200020 (de.openms.knime.startupCheck 1.10.0.201602200020)
    To: bundle org.eclipse.ui [3.6.0,4.0.0)
  Cannot satisfy dependency:
    From: Eclipse Workbench Model 1.1.100.v20150407-1430 (org.eclipse.e4.ui.model.workbench 1.1.100.v20150407-1430)
    To: bundle org.eclipse.emf.ecore 2.9.0
  Cannot satisfy dependency:
    From: Eclipse e4 Workbench SWT 0.13.0.v20150504-0621 (org.eclipse.e4.ui.workbench.swt 0.13.0.v20150504-0621)
    To: bundle org.eclipse.e4.ui.model.workbench 1.0.0
  Cannot satisfy dependency:
    From: Eclipse UI 3.107.0.v20150507-1945 (org.eclipse.ui 3.107.0.v20150507-1945)
    To: bundle org.eclipse.ui.workbench [3.105.0,4.0.0)
  Cannot satisfy dependency:
    From: Eclipse Workbench 3.107.0.v20150510-1732 (org.eclipse.ui.workbench 3.107.0.v20150510-1732)
    To: bundle org.eclipse.e4.ui.workbench.swt 0.9.1

The same happen with indigo, which is most important for me, as following:

annot complete the install because one or more required items could not be found.
  Software being installed: Indigo KNIME integration 2.0.0.v201602161642 (com.epam.indigo.knime.feature.feature.group 2.0.0.v201602161642)
  Missing requirement: Apache Geronimo Activation Plug-in 1.1.0.v201211130549 (javax.activation 1.1.0.v201211130549) requires 'package javax.imageio 0.0.0' but it could not be found
  Cannot satisfy dependency:
    From: Indigo KNIME integration 2.0.0.v201602161642 (com.epam.indigo.knime.feature.feature.group 2.0.0.v201602161642)
    To: com.epam.indigo.knime.plugin [2.0.0.v201602161642]
  Cannot satisfy dependency:
    From: Indigo extensions for KNIME Workbench 2.0.0.v201602161642 (com.epam.indigo.knime.plugin 2.0.0.v201602161642)
    To: bundle org.knime.base [3.1.0,4.0.0)
  Cannot satisfy dependency:
    From: KNIME Base Nodes 3.1.1.v201601211102 (org.knime.base 3.1.1.v201601211102)
    To: bundle javax.activation [1.1.0,2.0.0)

 

Could you help me there as well?