Cell replacer not doing what i would like

I have trouble using the replacer node. I have a large table with contract statusses and i have a smaller table with updated contract statusses. I want to replace the updated statusses in the large source table. To do is i have tried many things but i think the cell replacer node is the best option.

I put the large table as the input column and the smaller table with the updates as the library column. I have a rowid which i use as a lookup. After i execute i see no change. The contract statusses of large table remains unchanged. If i create a replacement table it contains all the values of the large input table. What am i doing wrong? I am getting a bit desparate

Cell Replacer is better for search and replace, but have you seen the column merger node?  You should be able to join your updated records to the master table with the Joiner node (a left outer join if you master table is in the top port) and then use the column merger to reconcile the two sets of records.

If this doesn't help, post an example and I can try to whip something up for you. 

Regards,  Aaron

 

 

Thanks Aaron! This worked like a charm. I had tried to join them before but did not know about the merger node. Now i merged everything, resorterted them and filtered out the old ones. I have been working on it all day, now I will be able to sleep ;-) Thanks again!