change knime.ini

Hi,

I need to change the xmx parameter inside the ini file and i have created a new ini with only this change:

-Xmx8192m

I'm trying the job under a server with 16gb of ram and a batch execution:

D:\"Program Files"\knime_2.10.4\knime.exe -nosplash  -reset
-application org.knime.product.KNIME_BATCH_APPLICATION
-workflowFile=X:\MKSAS\SW\P\KNIME_WKF\WKF\TEST.zip
--launcher.ini "D:\Program Files\knime_2.10.4\knime_XL.ini"

The log have a lot of debug rows like:

2015-03-19 11:45:40,965 DEBUG main RepositoryManager : Found category extension 'chemaxon_infocom' on path '/'
2015-03-19 11:45:40,965 DEBUG main RepositoryManager : Found category extension 'io' on path '/'
2015-03-19 11:45:40,965 DEBUG main RepositoryManager : Found category extension 'database' on path '/'

The ini seem to be accepted but the job doesn't start, the complete log is attached

Anyone can help me?

Thanks

 

It looks like the --launcher.ini parameter overwrites all other parameter given on the command line, especially the -application parameter. Did you try changing the order of parameters?

This trick doesn't resolve the problem...

There is another parameter -preferences

If i remove this parameter the job works fine

If i insert this parameter before or after the --launcher the job goes in error

Anyone can tell me why the preferences file attached avoid the execution of the job?

Thanks

Well...

If i try without the --launcher and with the preferences the job works

if i try with the --launcher and with the preferences the job doesn't work

if i try with the --launcher and without this line of the preferences:

/instance/org.knime.workbench.core/database_drivers=D\:\\Program Files\\Driver\\Oracle\\ojdbc6.jar;D\:\\Program Files\\Driver\\db2\\db2jcc.jar

the job works.

This job doesn't use these jdbc.

Anyone can help me?

Thanks

Does anyone have an idea?