ChatGPT: GPT4turbo

Hi All,
does Knime 5.2 (AI extension) support the leverage of GPT4turbo e.g. Agent Prompter node, LLM Prompter node?
Thank you in advance,
Armin

Hey @Armin_Alois,
The node you are probably looking for is the ‘OpenAI Chat Model Connector’ node. It has selections for ‘gpt-4’ and ‘gpt-4-32k’. As for the specific version of GPT4, you need to click on ‘Show Advanced Settings’ and under ‘Specific Model ID’ select the version ‘gpt-4-turbo-preview’ in your case. Check OpenAI Documentation for other version names if needed.

Here is a sample workflow on how to connect using an API key from OpenAI.

I hope this answers your question.

4 Likes

Thank you very much, Thor!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.