Chrome browser does not initiate

Hi,

I cannot start webdriver using chrome and here is the error message:

Uninstalling and reinstalling Chrome browser didn’t help.
Adding these arguments also didn’t help:
–no-sandbox
–disable-dev-shm-usage

:blush:

1 Like

Hi Armin,

received your email, but let me answer this here, as it might be valuable information in the future.

Could you provide more details regarding the environment? (especially operating system, and: is this a “normal” KNIME or a Server instance?)

Also: Did this work in this environment before, or is this a new installation?

Thanks,
Philipp

1 Like

Hey Philipp,

I’m trying to run the node in KNIME Server on Linux server.

Yes, it was running fine in this environment before. As far as I know we have not changed anything.
Not pretty sure how this issue started but I think it was after running a scraping job in which server gone very slow due to high resource usage.

Since then, we have uninstall, reinstall Chrome and restarted server but we still get the error message.
I googled the error message and found those arguments, applied them in webdriver factory but got the same error again.

:blush:

Hi Armin,

I had this issue with another client a while ago, also running on a KNIME server on Linux. Let me check my correspondence (it was a huge email thread) tomorrow and I’ll give some ideas.

In the meantime: Would switching to the bundled Chromium solve the issue?

– Philipp

1 Like

I tried Chromium and had the same error.

Hi Armin
chrome version 80.0.3987.163
no problem windows

I had a problem before because of the version. after the selenium update recently. It worked after updating the browser.

Updating and continuing this thread based on our email exchange with @armingrudd:

I’m aware of one case with a customer where something similar happened. The error was exactly the same: “DevToolsActivePort file does not exist”. They were running a KNIME Server with the Selenium Nodes and everything worked just fine (for years!) until suddenly it didn’t (unfortunately, I don’t have any records what was changed in the environment, probably a KNIME or OS update).

We did lots of investigation together with the KNIME support (@jeffgullick-knime), but were not really able to localize the issue. At the end, the customer re-installed the machine and the issue was solved (from a retrospective support-perspective, this is not really ideal, as we never found out what caused the problem).

The issue only occurred when the workflow was triggered via REST API or via the scheduling mechanism, not when it was run directly via the workbench’s GUI.

Anyways, to probably get some details, I suggest running this workflow:

https://nodepit.com/workflow/com.nodepit.space%2Fqqilihq%2Fpublic%2Fforum%2FSelenium_KNIME_Server_Debugging_22433.knwf

It will write some detailed log file to the home directory which might help to localize the issue.

Further points to check:

  • You didn’t modify the driver settings in the Selenium preferences – i.e. you’re using the default ones included with the plugin?

  • You tried running “Chromium (bundled)” and you’re having exactly the same issue compared to running the system’s Chrome browser?

  • Which Chrome version is installed on the server? Was it recently updated? Can it be successfully started locally?

  • Is there any security software, firewall, etc. which might interfere or prevent launching Chrome?

  • Can you rule out any permissions or privilege issues? (i.e. does the user which is executing the KNIME processes have enough rights to launch the browser?)

  • Out of curiosity: Does running a Firefox browser work?

– Philipp

2 Likes

I’m answering this here, as I still consider it of general interest.

You sent me several log files running the above diagnosis workflow:

  • The headless runs (with the --headless args) seemed to work fine (see chrome_webdriver_1586439532361.log, chrome_webdriver_1586439785229.log, chrome_webdriver_1586801702040.log) – correct?

  • The non-headless runs (without the --headless flag) errored (see chrome_webdriver_1586439805260.log, chrome_webdriver_1586813960150.log, chrome_webdriver_1586815404533.log). The error is shown in the log:

    [107730:107730:0409/200826.335969:ERROR:browser_main_loop.cc(1512)] Unable to open X display.
    

    If you really want or need to run non-headless (any specific reason for that?), you’ll likely need to start a virtual display. Look for Xvfb. (see also “So I still need Xvfb?”)

Beside that, the logs show this:

[1586439734.288][INFO]: Starting ChromeDriver 79.0.3945.36 (3582db32b33893869b8c1339e8f4d9ed1816f143-refs/branch-heads/3945@{#614})
…
[1586439734.402][WARNING]: This version of ChromeDriver has not been tested with Chrome version 80.

Please make sure to run a recent version of the Selenium Nodes (as of today, the current stable version ships with 80.0.3987.106, the nightly build with 81.0.4044.69).

Generally, I recommend to use the “Chromium (bundled)” instead of a system-wide Chrome, especially when running on the server – this ensures that the browser and driver combination are compatible.

– Philipp

1 Like

Hi @qqilihq,

Thanks for your reply here.

Yes, chrome runs fine in headless mode but why has it stopped working in default mode? (it was working fine before)
Also, I’m going to ask if it doesn’t really make any difference running chrome headless?

About the version, we installed chrome 79 and we got the same issue. The last 2 logs I think are made using chrome 79.
None of webdrivers are working like before, including Chromium which throws exactly the same error.

Will check the Selenium version installed on server. I think it was updated, but will make sure about that.

Thanks again Philipp for your support.

:blush: