Column list loop skipping the first iteration?


Hope you are well. I am experiencing a problem in KNIME which I was hoping someone would be able to help with…

What I am trying to achieve

  • I am creating a workflow where a user will upload a tagged dataset in a “messy” format and then the workflow reformats this like the app template file so it is suitable for one of our internal apps.
  • There are a select number of headings in the app template file and so the user maps their tagged dataset headings to the app template file headings using widgets. They do have the ability to chose “N/A” if one of the app template file headings isn’t within their tagged dataset.
  • One of the tagging letters is “A” which basically means that the contents of the row needs to be duplicated to all of the row below it.

My current approach

  • I have extracted the rows that have the tagging “A” and removed the headings (as these could vary depending on the file that the user uploads) so now just shows Column 1, etc.
  • I have extracted the columns which were mapped as “N/A” so unassigned and converted these to a variable. This variable feeds in to the single selection widget and controls the possible choices
  • I am using a column rename (regex) to then rename Column 1 to the name selected in the widget

The problem

  • When I create a component containing these nodes it seems to skip column 1 and just go straight to column 2 (N.B. the number of columns could vary dataset by dataset)
  • Is there any way of working this so all of the columns are displayed within the widget at the same time? Or alternatively is there a better way of doing this?


First question. Is it possible to provide the template to the end user? This would be the best approach
if not possible fine , just want to rule out the best option even if it’s probably obvious


Thanks for the reply.

In the past we have provided the template to the end user but to be truthful a lot of users aren’t exactly sure how to get the data in to the correct format in Excel hence the reason for automating the task.

What I maybe should have said in my original post is that there are a lot of other strands to this workflow however this is the particular section I am struggling with.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.