Column Splitter node - Strange Behaviour

If a workflow is set up with a "column splitter" node where columns are passed either to the top out port or bottom out port, and then the input data into the workflow is modified such that there are additional columns then strange behaviour is observed at this splitter node.

The additional columns are filtered out, in that they neither appear in the top out port or the bottom out port. Please can an option be given in the node, like the column filter node, with the "force inclusion" option. So that a "force inclusion" on the top port means any new additional columns will automatically be sent to the bottom port.