command line execution on Mac


how do I start the command line version of knime on a Mac? 

Do I really need the Developper edition for this? If not how do I start it?



Hi Bernd,

I've just extended our FAQ entry about running KNIME in batch mode by an explanation for Mac.

The call should look like this:

/Applications/knime/ -nosplash -application org.knime.product.KNIME_BATCH_APPLICATION


Hi Dominik,
It’s been a long time since you posted and the documentation is still vague.
My problem is that I cannot get Knime 4.1.0 to run in batch mode on the Mac with your instruction, even if I change your path instruction to the current version “KNIME”. Terminal / Shell says “command not found: Knime”.
Is there anything I have to consider for the current version?

Hi Max,
Did you try and put some quotes? KNIME is installed in a directory that contains spaces so I tried to add some quotes around it and it worked for me. Like this:
/Applications/“KNIME”/Contents/MacOS/Knime -nosplash -application org.knime.product.KNIME_BATCH_APPLICATION

Don’t know if that the problems you are having but it might be worth a try.

Note: I’m also running 4.1.0 but in my applications directory it is called 4.0.2. Don’t know why that is. However, to find out the path you need to give to Knime in your terminal. You first open Finder and go to Applications and when you find Knime you “right-click” on the icon and select “Show package contents”. Find the Knime executable and then “right-click” again on that one and select “Get info” to see what the path to the executable actually is.


Hi wispet,
yeah, great, your advice with the quotes helped, thank you. However, only the single quotation mark ’ works for me:

/Applications/'KNIME'/Contents/MacOS/Knime -nosplash -application org.knime.product.KNIME_BATCH_APPLICATION

Happy New Year!