Compiling Rserve 1.8-6 on Windows 7 (64bit)

Because I never found this advice anywhere I thought I’d leave it here to potentially help others:
tl;dr On Windows 7 (64bit), try compiling the Rserve package like this:
install.packages("Rserve",, "", type = "source", INSTALL_opts = "--no-multiarch"))

The longer version:
After updating the R installation that I was using with Knime from version 3.4.4 to 3.6.1, some R nodes in my workflows started failing. I quickly found that with R >= 3.5.0 you need the latest Rserve 1.8-6 in order for Knime to to be able to talk to R properly. However, for Windows there was no binary available so one has to compile the package which requires that you have the proper Rtools installed on your Windows system (RTools: Toolchains for building R and R packages from source on Windows). The advice I found was to then call
install.packages("Rserve",, "", type = "source"))
but on my Windows 7 (64bit) system, the compilation would always fail after half a minute or so.
The Rserve website (Rserve - Binary R server - says:

Rserve requires no special handling and can be compiled like any other R package. The only detail is that the resulting libs directories may have to be merged manually for multi-arch R (i.e., you use --arch x64 to create 64-bit Rserve and --arch i386 for 32-bit Rserve versions in multi-arch R) since R copies only .dll files but not .exe files.

which pointed me in the right direction. Eventually, what worked for me, was to compile the package like this:
install.packages("Rserve",, "", type = "source", INSTALL_opts = "--no-multiarch"))


Hi there,

tnx for sharing! Adding reference to R topic where you already posted.


hi @mattflor,

i had the same problem and got it solved with the installation of RTools.
Now my workflows are running fine againg. :grinning:



This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.