Component views suddenly not working

All of a sudden today, I started experiencing problems with composite views from components, at least in a particular workflow. A component containing some tag clouds and table views, which had worked fine for days, suddenly stopped rendering anything when I executed it and selected the interactive view (I’m just working within the Analytics Platform, not the Web Portal). The view window popped up, but it was just blank. Meanwhile I could load each individual view from the component just fine, or open the views of each individual node without issue.

I have done everything I can think of to find the problem, but after losing most of a day to it, I have given up. Here are some of the things I’ve tried:

  • Stripping out the nodes in the component one-by-one until the component rendered. In most cases, it never worked even when there was only a single node left in the component.
  • Expanding and re-creating the component.
  • Switching the input port of the component for a saved table containing the same data.
  • Reinstalling KNIME (I recently upgraded to 4.4., which I suspect might have something to do with the problem) and rebooting my PC.
  • Copying and pasting the contents of the workflow into a brand new workflow.

Almost none of these things helped. On a few occasions, I got the view to work by stripping nearly everything out and using a tabular input, generally after pasting everything to a new workflow.

On one occasion, the whole component rendered successfully within the full workflow just after I reset an upstream DB connection that had expired. I wondered if this had been the cause all along, but since then, it usually doesn’t work regardless of whether or not the DB connection is active (or indeed if it is replaced by a local table).

I have done one test where I built a new simple workflow from scratch, starting with a random number generator and producing a bar chart and tag cloud in a component, and it worked fine. So my installation is certainly capable of producing composite views. (Just not the ones I want!)

There is more testing I could do (going through other workflows, finding another machine to try it on…), but for the moment I have run out of time and would love to hear some ideas about what could be going on.

Any ideas would be greatly appreciated.

Hallo @AngusVeitch1,

Sorry to hear that you are experiencing those problems. Could you maybe share the workflow with the component? Then I will look into that.
In the mean time, could you also tell me which browser you are using to display the composite view? You can find that out under Preferences>KNIME>JavaScript Views and there should be a browser selected.

Kind regards,
Janina

1 Like

I’ll see if I can export the relevant part of the workflow later today. I’m using the bundled Chromium browser (Version 91). I tried selecting the CEF browser (with no path specified), but KNIME just quit itself instantly whenever I tried to open a component view. I started looking into how to set up a CEF browser, but it looked complicated. Happy to try an alternative if there are some clear instructions!

Just an update. I’ve now encountered the same problem in a different workflow. This time the component contained nothing but a Table Editor and a row filter. If I copy the component to a new workflow and use a saved table as input, the composite view works. BUT, if I route the same saved input to the component within the original workflow (breaking its connection with everything upstream), it still doesn’t work. So there’s something about the workflow itself that is causing the problem.

In both cases, the original workflows are complex and full of DB connections that won’t work if I export them. But I’ll see if I can isolate something that can run on its own while still exhibiting the problem. Or I’ll just share an original workflow so you can at least see what is in it.

Ok I think I’ve figured it out. The component views do not work if the component is inside a metanode.

Many of my components are within metanodes, because they are intended to be used within the desktop platform rather than the web portal. These all worked fine up until the latest release. Now, I need to expand the metanodes containing the components in order for their interactive views to work.

I hope that this is an oversight in the latest release rather than a design choice, as I really need the composite view functionality to work within metanodes when used in the desktop platform.

(As an aside, I would really love it if component views worked from within metanodes in the web portal as well, but that’s a conversation for another time.)

Assuming someone can replicate this behaviour, can we hope for a fix in the next release?

2 Likes

Thank you @AngusVeitch1 for that valuable input! I can replicate this behaviour on my end and we are investigating. This is definitely a bug and not a design choice. We will keep you posted.

(and regarding component views from within metanodes in the WebPortal: if you like you can post it in the Feedback & Ideas category - would be interesting to know what your use case is)

3 Likes

Great to know, @hornm . I’ll look forward to any updates.

I will do a separate post about components in metanodes on the web portal, but my reason for wanting to do it is simply workflow organisation. I have made some complex web portal workflows that include component views within loops (this can allow, for example, the user to make decisions about multiple columns in turn). These workflows can get quite messy, but I can’t put such loops in metanodes, as the component views will no longer work. Anyway, I’ll make that a separate post as you suggest.

Hello @AngusVeitch1, I just want to let you know that the latest version (4.4.1) of KNIME Analytics Platform now contains a fix for the problem you brought up here. You can either download it from here or just update your KNIME Analytics Platform (Menu > File > Update KNIME …).

Best,
Martin

5 Likes

That’s great news, thanks Martin!

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.