Concatenate Bug?

Hi guys,

I don’t know if I have a lump in my brain or the Concatenate node is not working as it should.
I wanted to create an intersection of records, but only get a union of the two table contents. Both tables shows the same entries.

Could you please check if I am making a mistake or if the node is not working as desired?
The workflow was tested with KNIME Versions 3.6.1 (Sep. 2018), 3.7.2 (Apr. 2019) 4.0.2 (Oct. 2019) and 4.1.1 (Feb. 2020). OS Linux Ubuntu 18.04.4 LTS.


ConcatBugTest.knwf (12.9 KB)

Hi @Andrew_Steel,

The node is working as expected. The two options “Use intersection of columns” and “Use union of columns” have nothing to do with rows, if tables have different columns then these options play a role.

If you need to include the same rows appearing in both tables (based on a column value), the Reference Row Filter node is what you can use to include rows from the top table which appear in the bottom table (reference table). If you need to match several column values for filtering, then the Rule-based Row Filter (Dictionary) node is the one to use.



Hi @armingrudd.

Ow! Damn! Yes, I have a lump in my brain. Of course. The settings are column based not row based. That’s what it says in the settings.

Thanks a lot Armin


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.