Configuration node in a shared component on KNIME Server

I have a shared component that uses two Configuration nodes.

When I deploy the workflow to KNIME Server and execute the configuration does not show up in the “Configuration options” tab.

This workd for Configuration nodes that are located in the workflow directly.

Is there a way to propagate the Configuration from a shared component somehow so that I can set configuration when executing on KNIME Server?

Hi @mpreusse,

just to make sure - do you mean in the remote workflow editor? It can well be that there are differences between workflow editing and Server-Job-editing - if that’s the case, could you please share a (dummyfied) component/workflow snippet so that I can investigate?

In case you execute the workflow from the WebPortal you won’t see the configuration options of the configuration nodes, because they would only show up if you double click the component (the configuration nodes are intended to make components behave like nodes themselves). If you want the workflow to be configurable from the WebPortal, you’d use the widget nodes (e.g. the String Widget or the Integer Widget) - they will show up as a nicely rendered input for the DataApp consumers. (There are the legacy quickform nodes which offer both functionalities, but I won’t recommend them as they come with some inconsistencies themselves).

It depends a bit on what you want to do, but I think in your case it would be reasonable to unshare the component (right click it in the workflow → Component → Disconnect Link), open it up (Strg + double-click or right click it → Component → Open), and replace the configuration nodes with the respective widget counterpart. In case you don’t want to loose the link, you can create a “configuration component” containing the respective widgets yourself, place it before the shared component and feed the configurations via flow variables.

Please let me know if that helps!
Best regards,
Lukas

Thanks @LukasS! I have not used the WebPortal yet.

I developed a workflow locally in KNIME AP and added a shared component. The component contains a configuration node so that I can pass data into the component.

Next, I deployed the workflow and the shared component to KNIME Server by dragging and dropping to the Server in KNIME AP.

When I execute the workflow on KNIME Server from KNIME AP there is a window asking for settings. However, in the Configuration options I can only set config values for Configuration nodes that are located on the top level in the workflow itself, not the ones that are in the component.

Have a look at this workflow:

When I execute this on KNIME Server from KNIME AP I can only set the String Configuration of Node 5, not the config that is stored in the component (workflow is attached below).

There is a way to work around this by pulling the Configuration node out of the component of course. I’m just relatively new to KNIME and KNIME Server, I really love shared components, and I’m trying to understand how all of these things work together :slight_smile:

test_component_server.knar.knwf (12.9 KB)

2 Likes

Ahh, that feature is new to me, thanks for showing this so detailed @mpreusse! :slight_smile:

Right, as you observed, it only takes the top level configuration nodes into account for the execution configuration options. After playing around with it I’d suggest to leave the shared component as is and add the configurations you want accessible in the execution configuration options on the workflows top level like shown here with a “componentconfigurator”:


In case you want to have multiple configurations accessible, there are two methods to combine the respective flow variables (I know of), either with the merge variables node or by concatenating several configuration nodes - make sure to use unique parameter/variable names or they will overwrite each other.

Then in the components “Flow Variables” configuration tab you’d set which flow variable to use for which configuration:
image
More on flow variables (super useful!) you can find e.g. in the self paced courses.

Here is your modified workflow: test_2_component_server – KNIME Hub

Greetings,
Lukas

4 Likes

Thanks for the help & explanation @LukasS!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.