Connecting Knime 3.6 with Tableau Node ExctractAPI error


I have downloaded the Tableau SDK and placed it both in the KNIME Workspace and in Tableau’s program files. I have configured the linked resources page of the KNIME to point to each file individually and to the bin directory.

In addition, I have edited the Windows System variable PATH and added in the new \BIN\ directory; I have also downloaded the Visual C++ Redistributable Packages for Visual Studio 2013, the 64-bit version I found from here:

I updated the environment variables for ‘Path’ on my system.

After executes, I first get a library not found. Then on subsequent executions, I get the error.

Does anyone know how to properly set up KNIME’s environment to successfully use the Tableau connector?

Hi @pandawid -

Can you make sure the system PATH variable (and not the user Path variable for your account) points to the /bin directory of the SDK? Here’s how mine is setup:

Hi @ScottF

After changing a system PATH variable and still have the same problem as before.

I think the problem is I’m trying Java 32-bit, with a 64-bit system, but I cannot download correct Tableau SDK.

It looks like it’s a dead link on Tableau’s end. Here’s the Windows Java 64-bit version of the SDK that I am using:

EDIT: link removed

Also, you may already be doing this - I can’t tell because it may be getting cut off by the interface - but make sure your system path is pointing to the /bin subdirectory.

Can u grand me an access for download?

Thank you for your help!


I’ll send you an email directly.

Dear All,

Do you know what the solution of this problem?

I am new to KNIME and would like to export my simple workflow to tde. I did every as per instruction, using Tableau-SDK-C-Java-64Bit-10-3-16 and added path in the system PATH variable.

I am running the latest version of KNIME, which I believe 3.6.2 but still encounter the same problem, which is.

ERROR Tableau Writer (TDE) 0:11 Execute failed: Could not initialize class com.tableausoftware.extract.ExtractAPI

Anyone can help please?

The path I am using in my Windows environment variables for this tableau SDK is


Anyone can help with the above issue?
Can we get some help from KNIME experts here?

Hi @fikristar -

Could you try removing the multiple paths under your linked resources? You should only need the one that points to the correct /bin directory.

The other thing is check very carefully the paths that you have entered for stray characters - the paths must match exactly.

You might also cross check what you did the the instructions on this page:

Hi Scott,

Thanks for the suggestion. It works!

one more question, I was trying generate output from database reader and tableau writer. The flow worked and did not give any error message. I can see the output from Database reader and a tableau tde file was generated. The tde file is so small though.
Nevertheless, when running the tableau file, there’s no data there and it is showing error.

Any hint or advice? What can tableau writer node be connected too? does it work with database reader?

And this is the error message I see on tableautableau%20error%20message

Hi @fikristar -

Would you be able to upload a minimal example workflow with some dummy data, so that I can reproduce the error and attempt to troubleshoot? This isn’t an error I’ve seen with the Tableau integration before, so it’s something that may need followup with the development team.

Hi @ScottF

I’ve been using the “Send to Tableau Server” node quite frequently and it works quite well for my workflows.
However, very recently I have been encountering an “Execute Failed - Item Number mismatch” error. I have tried with multiple types of data sources and it still fails.
I have noticed that within my company the Tableau server has been upgraded to 10.5 and by looking at the Tableau website, they no longer use the older SDK to create .tde files. Instead for the newer tableau version, they use the Extract API to create .hyper extracts now.

Can you look into whether this node needs to be updated to look at using the new feature creating a .Hyper extract? Or provide a feature that can create a .tde extract or .hyper extract?
Any help would be much appreciated.

Hi @johanjg911 -

We have been working on updating the Tableau integration for the next release, so generation of .hyper files should be available soon. :slight_smile:

1 Like

Even we are getting the same error. This behaviour is weird as the same node is publishing to all the projects in a different tableau server but unable to publish into almost all the projects for anther server.

Hi @DeepakPadhi -

The item mismatch error is popping up a lot in the forum this week. You mentioned that the Send to Tableau Server node works for one of your servers, but not the other one. Do you happen to know what version of Tableau Server those machines are running, and if they’re different? I’d be especially curious to know if the most recent version of Tableau Server (10.3) is associated with the problem.

EDIT: My mistake, the most recent version is 2018.3

Both the servers are 10.5.3

That’s good to know. I’ll see if we can make any headway on finding what may have changed on the Tableau side.

Hopefully the imminent release of KNIME 3.7 will make this problem moot, but it would still be good for us to understand what’s going here. Thanks for the info.

Hi Scott,

Do you have any idea why we see this error?