Connecting to SQL server database using windows authentication

Hi there,

 

I ma having some issues connection to SQL server using windows authentication. When I enter my windows user name and password I get an error. I have no issues if I use a normal sql server account. Have tried range of username options but with no success.

 

Thanks

This post might be helpful to solve this issue. Please let me know.

Thanks Gabriel. Have tried following the recommendation but I am still having difficulties. I am getting the following error. I added the requested dll file directory to the twindows system path.

 

WARN      Database Reader                    java.sql.SQLException: java.sql.SQLException: com.microsoft.sqlserver.jdbc.SQLServerException: This driver is not configured for integrated authentication. 

Ah sorry, I attached the wrong post, please read through this thread for further details.

Hello,

 

Apologies for commenting on an old thread. I am trying to connect to sql server with windows authentication. I have pointed KNIME at the sql server driver, and I have added the DLL file into the same location as the sql server driver, but I still cannot connect.

 

Do the driver and DLL have to be located in the KNIME folder in Program Files, or do they need to be in another location?

 

Thanks

 

L

Can these instructions be updated for Knime 2.10.1 as the driver definitions dialog is now a lot more complicated? To add the JDBC driver for SQL Server, please can you answer the following questions:

  • What name/type of driver do I need to add? I assume Generic JDBC driver?
  • For the Jar list do I add sqljdbc.jar, sqljdbc4.jar or both?
  • In the properties dialog what do I enter for Connection URL, Database name, driver class and userId. All of these are required fields before Ok becomes active but there is no explanation as to what they all mean.

So I've added a generic JDBC driver, both jar files, some random text for driver class and entered my windows id for UserId however when I add a database reader my new entry does not appear in the drop down for database driver.

I've also tried the JTDS driver as well to no avail.

Some new documentation on this would be appreciated. Thanks

Following our database documentation, I assume you have added one of these driver files within the File > Preferences > Database Driver section. If you then open the node configuration of the Database Reader you should be able to select com.microsoft.sqlserver.jdbc.SQLServerDriver as Driver and specify the URL as jdbc:sqlserver://<server>:1433;databaseName=<name> and your database credentials which does not necessaryly need to be your Windows login. Please let me know if this helps.

HI, yes I have looked at this but the database documentation does not look anything like the actual application. In Knime 2.10.1 I have Preferences-> Data Management -> Connectivity->Driver Definitions. For each of the drivers there are three tabs Name/Type, JAR List and Properties.

The preference page you are referring to does not come from KNIME but from the Eclipse Data Management Tools. All KNIME settings are in the "KNIME" branch of the preferences.

Thanks for this, this solved the problem

I have tried all the above recommendations; nothing worked so far. Any other ideas, please?

ERROR     Database Table Connector           Execute failed: com.microsoft.sqlserver.jdbc.SQLServerException: The TCP/IP connection to the host localhost, port 1433 has failed. Error: "connect timed out. Verify the connection properties. Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port. Make sure that TCP connections to the port are not blocked by a firewall.".

Even when the firewall's disables !

 

 

Diegres, can you please send me a screen shot of you settings from the Database node?

Here it is. Thanks, Gabriel

Sorry for delay, I guess the URL need to read as .../databaseName= ?