Connection Knime database by command line

Hi everyone,

I try to connect by command line at my workflow :
C:\ProgramFiles\KNIME\knime.exe --launcher.suppressErrors -consoleLog -noexit -nosplash -application org.knime.product.KNIME_BATCH_APPLICATION -workflowFile=“C:\Users\mcsanchez\Documents\Tableau Nanook_sedna\nanook_agglo\Nanook.knwf”

But I have an error message: ERROR KNIME-Worker-0-MySQL Connector 0:1 Node Execute failed: Access denied for user ‘root’@‘localhost’ (using password: YES)

Do you know the command line to resolve that ?
Maybe with a -user and -password but this things does’nt exist ?

And Do yo know the command line for connect at a specific data base with a -workflow.variable ?
I think it’s with that like “-workflow.variable=SQL, …”

Thank you for your help.

Hi @marie_s74,

have you tried running this worklfow not from the command line but from the GUI? Maybe the configuration of that node is not set correctly? Regarding your second question take a look at:


I made all my workflow in GUI and that’s work.
Now I need to automate the launching knime and generating my final file by commandline.

HI @marie_s74,

The workflow you are trying to run works in the AP without you entering a password? If you need to provide a password during runtime, then you need to expose it with a workflow variable, those you can control from the command line.


Hi @gab1one,

Yes like I said earlier I try without my password, so I have an error it’s logic.

But I don’t understand how in the workflow.variable in my command line pass my password .


You can right-click on a workflow to create a workflow variable, also you can control the variables defined by quick form input nodes, as long as they are contained in a Metanode.


I had try this but in command line I try to authentifiate with workflow.variable Or credentials but that tell me the option doesn’t exits…

I solved my problem, with mysql connector the command line with credentials doesn’t work, we need to make all this with a db connector

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.