Connection to h2 database file fails

Hi everyone,
my goal is to read a H2 database file into KNIME = to establish a connection to a H2 database file stored on my machine.

  • What is the difference between the H2 connector and the H2 connector (legacy)?

I think I shall use the “H2 connector”, right?

I inserted the “H2 connector”. I opened the configuration. I typed the path in. When I executed the node, it did not work.

I have read around online, but I could not find any hints so far.

Where could the problem lie and what shall I do to succeed?

Do I have to install something etc.? I just got the H2 file via an usb-stick.

Thx!

Cheers, Eva

1 Like

Hello @EvaHH welcome to the KNIME community,

could you give us some more details about the file and the ending maybe a screenshot from the settings of the node.

If possible the database itself would be very helpful but that might not be possible due to privacy concerns.

You could check out this example of the usage of H2 databases and see if you might be able to draw any conclusions.

In any case I would advise to try everything with a copy of the original DB so that you might always be able to start fresh if needed.

1 Like

Hi @EvaHH,

Correct. Database legacy nodes belong to older database framework and if no specific reason it is suggested to use nodes from newer database framework.

Don’t need you need to install anything. Did you get any error message?

Br,
Ivan

Many thanks for the warm welcome and your help!

So from what I understood from your comments: I need to use the H2 connector and it is perfectly fine to just have the H2 database file on my machine. There is no need to install anything else.

These are the screenshots. I was wondering if I have to change any of the “advanced” settings - any ideas? What else could the problem be?

Thx and cheers!
Eva

Hi @EvaHH,

what is the error you get? Check Console in KNIME or hover over red sign under node.

Br,
Ivan

Hi ipazin,
oh great, I did not know this function!

image

The dabase file has a passwort, that is correct. Where do I put this in? Maybe that’s the solution, that would be so cool!!

Thx and happy weekend.
Eva

Should work with JDBC parameters:

I added this example to my workflow from the hub. You could check it out again.

1 Like