Continental – installation XLS Extension

Hi there @Tom,

Interesting theory regarding cause :face_with_raised_eyebrow:

Have you tried with a fresh installation of KNIME Analytics Platform?


1 Like

Hi @Tom,

can you tell me the exact version of the continetal plugin? You can find it at Help -> About KNIME Analytics Platform -> Installation details.


Hi @gab1one I upgraded Knime from 3.6 to the newest version 4.1.3 and install Continental Nodes for KNIME - 1.2.0.v202004281515.
I also made a fresh Knime installation form zip file.

@ipazin it’s not only a theory :slight_smile: Today we made an experiment. Computer with this problem is a kind of server, because I share folder with Knime installation in network and allow another users to run Knime only in runtime mode using batches and prepared workflows. As I said, when admin run Knime on this “server” (don’t have MS Excel) we can see nodes with XLS formatting options from Continental. If we use another computer (never had Knime installation, but has MS Excel installation) and run Knime from shared “server” folder the nodes appear!

So We supposed that the problem with lack of some Ms Excel library’s…

Best Tomek

1 Like

Hi @Tom,

try updating the KNIME installation, the latest version of that plugin is: 1.2.0.v202005250952, it contains a small change that should fix this issue for you.


1 Like

We update the Continental extension but it doesn’t helped :frowning_face:


In that case can you try re-installing the extension?

Unfortunately, the extension was uninstalled so we install them again, but still nothing happened.
On the computer on which there is Ms Excel and we launched Knime from shared localization - everythink is OK.

Hey, today we made another tests.

  1. We install Ms Excel on the server, but it doesn’t helped.
  2. We use another computer without Ms Excel and run Knime form shared folder from server and everything was ok, so it’s another kind of problem.
    Admin now installing patches in OS - windows 2012 R2 Standard Edition, and we will see if it help…

In tha meantime, admin installed Knime on the other serwer and everything was ok…

After install all Windows updates on the main server - everything work properly - thank you guys… my admin is :+1:


Hi Tom,
Glad to hear that the problem is solved now. Thanks for reporting the issue. As @gab1one says, there was a minor fix in the latest release which we hope to fix this issue.
Just to clarify for other users as well: The extension does not require an Excel installation. All libraries used are included in KNIME itself (not even shipped via the extension).

1 Like

Hi @arbe your last sentence i true - Knime don’t need Excel installation. But my problem didn’t gone, unfortunately. Next day, all XLS nodes from Continental Extension gone :frowning_face:

My admin gave me new server with clear system. I made some test on Knime 4.1.3 and my summary is:

  • XLS node appears only in version 0.8.2

  • when I installed continental version 1.1 and 1.2 it’s only “utility node”

I will use lowest version of this extension but I have a problem with existing workflows. I supposed that the resolved is in version 1.1:
•added “from long/unpivoted layout to wide XLS Control Table” option to XLS Control Table Generator

in 1.2 node XLS Control Table Generator show:

and in 0.8.2

after use Rule Engine node I can’t roll it back to the good view



all settings are the same in both versions

in console there is:
WARN XLS Control Table Generator 0:1102 Warning: The generated table is not yet a valid XLS Formatter Control Table as it contains invalid characters in some tags.

Hi @gab1one, do you have any concept what can I do, becouse I run out of ideas :frowning:

Hi @Tom,
That the older versions of the extension can not work with workflows created with newer versions is expected behavior.

As I understand, you are using the older version of the continental extension because the current one does not work on your server? I think we should focus on getting it running there then.

Maybe you can get your admin in contact with us?


Hello @gab1one, my admin is watching this issue.

In conclusion:

  1. On the main server where we upgraded Knime to 4.1.3 version and installed Continental extension we can see xls nodes only in version 0.8.2. When we installed version 1.1 or 1.2 - they gone. Operating system is Windows Server 2012 R2 Standard
  2. Admin run only for me - new server with Windows Served 2019 Standard and Knime 4.1.3 - the situation is the same.

On my personal computer every think is ok (Knime 4.1.3 + Continental Extension v. 1.2). When I installed Knime on my colleague personal computer with Windows 10, every think is OK still. It’s seems that the problem is only on servers?

Hi, we recently discovered these XLS editing nodes from Continental and wanted to use them but as stated above we only see the Network node.

We tried on our institute machines with Windows 10 and KNIME 4.1.3 as well as my Mac with always the same result. Seems to be a strange and severe issue. The version tried is 1.2.0.v202005250952

Is there any solution available?

Many thanks!

Hey @laval, try to install Knime 4.2 version. Two weeks ago when I back from a hooliday, and I tried again to solved the problem. Forntunatelly new version of Knime was appear - helped me in 100%.

I second @Tom here, please try with 4.2.


Hey, we tried the 4.1.2 and there it works fine. But we just updated the whole institute from 3.7.2 to 4.1.3 including the KNIME Servers and now we can not go back.
I also tested LInux this morning with 4.1.3 and have the same result. Therefore, as stated the issue is 4.1.3. Can we get a fixed version of the nodes?
Furthermore, the 4.2 also works . . . but the next update round will not be this year
due to the huge effort.


Hi @laval,

I just tried to reproduce this issue on 4.1.3 and indeed the xls formatter nodes were not initially available after installation. I was however able to restore them by starting KNIME AP using the -clean parameter once. I did this by navigating to the installation location on the command line and executing
./knime -clean.
This should get you started with relative little effort.



Hi @gab1one,

I tried the -clean command and it helped to let the nodes beeing visible.
That will work for now.

Thank you,

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.