CSV reader scan limit (rows) problem

Hoi zäme

I am having problems with the csv reader (KNIME 4.1.3 I believe). I have to read Norwegian climate data asc file i.e. text file of which the first six lines are metadata, the rest is payload. However, I try to read only the first six lines to put them a way in a metadata table but I seem to miss something as I get the following exception. Or it is a bug.

org.knime.base.node.io.filereader.FileReaderException: Too many data elements (line: 7 (Row6), source: 'file:/mnt/norge/1985-2014/rr_1985-2014_01.asc')

Please find attached a test case.

Kind regards


CVS_Test.knwf (4.8 KB)
first_seven.zip (239 Bytes)

Hi Thiemo.Kellner,

you have to use the limit rows option instead of the Scan Limit (which is used to analyze the file i.e to dertmine the column types etc.) like in the screenshot and you will get what you want :slight_smile: The error is probably because the first six rows have only two columns and the seventh has got ~ 7000 and the reader ist not able to fill the first 6 rows with empty cols, but you could just tick the “Support short lines” option in the Settings tab. Instead of the csv Reader you could use the File Reader which offers you some more advanced option or you could use the new CSV Reader which comes with the 4.2. release next week.

Hope this helps!

Best regards


Hej Lars

Thanks for your reply and the solution. I wonder what I did experimenting with the options… :roll_eyes:

Kind regards


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.