CSV Writer problem


Is there a possibility to force the Knime server to use a specific encoding value when writing a CSV file? We are using a Knime server on a Linux machine and users have windows PCs. We get wired characters when opening CSV files on our local PCs. I know we can get around this when opening the file in Excel but it is quite painful when you are dealing with many files.

I’m not an expert on this type of issue but can we find a way to get these Windows and Linux worlds talk to each other nicely?

Thanks in advance for your help,


Currently you can only change the encoding on the server on a global level via a system property in the ini file for the executor: -Dfile.encoding=CP1250 (if CP1250 is what your other Windows application uses). I would not recommend it, though, because this may break all kinds of other nodes because the default under Linux is UTF-8.

Hi Claire,

instead of changing the default encoding on the server you can also change the encoding when reading files on the client. Use the File Reader node to read the CSV file, generated on the Linux server. In the dialog of the File Reader you can click the "Advanced" button. An advanced settings menu will open and there you can specify the encoding to use for reading the file. Change the encoding to UTF-8. I hope this helps.

I hope this helps.

Cheers, Kilian